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Overview of Using AutoCAD with External
Databases
When you link database records to graphical objects in a drawing, you can
use powerful database queries to filter and sort information. You can present
the results of a query graphically.
A database is a collection of logically related information, usually presented
in a table format similar to a typical spreadsheet. The table below is an example of a simple database that might be used by a Facilities department to
schedule maintenance work. It consists of four columns, or fields, labeled
Maintenance task, Estimated hours, Frequency, and Assigned to. Individual
fields, or cells, store data for a particular variable. Individual rows within the
table are called records.
Maintenance database table
Maintenance
task

Estimated
hours

Frequency

Assigned to

ELEVATOR SRV

3.5

QUARTERLY

RON SMITH

CARPET VAC

5.25

WEEKLY

VICKI ROBERTS

A/C CHECK

2.00

BIWEEKLY

AMY REED

AIR FILTER

3.00

MONTHLY

DAT TAN

Most database systems are extremely flexible and can be easily modified. You
can add new fields or remove existing ones from tables. Likewise, you can
add or delete records from tables and edit existing records. With many databases you can also define relationships between multiple tables. For example,
suppose you have two tables that share a common field, Room ID. Using a
relational database, you can join these two tables using their common field.
You don’t have to maintain and input duplicate data across multiple tables.
You can use AutoCAD to associate data contained in an external database
table with AutoCAD graphical objects through the process of linking. Links
are pointers to a database table that reference data from one or more records
in that table. You can also use AutoCAD to attach labels that display data
from selected table fields as text objects in your drawing.
The AutoCAD database connectivity feature provides the following:
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■
■
■
■
■
■

An external configuration utility that enables AutoCAD to access the data
contained in a particular database system
A dbConnect Manager where you can associate links, labels, and queries
with AutoCAD drawings
A Data View window that displays records from a database table within an
AutoCAD session
A Query Editor where you can construct, execute, and store SQL queries
A migration tool that converts links and displayable attributes to
AutoCAD 2000 or later format from files created in earlier releases
A Link Select operation that creates iterative selection sets based on
queries and graphical objects

Access a Database from Within AutoCAD
When you have configured a data source, you can view and edit its records
from within AutoCAD.

Configure a Database for Use with AutoCAD
Drawings
Before you can access an external database from within AutoCAD, you must
configure it using the Microsoft ODBC (Open Database Connectivity) and
OLE DB programs. Using ODBC and OLE DB, AutoCAD can utilize data from
other applications, regardless of the format that it’s stored in or the database
platform that it’s created on. The configuration process involves creating a
new data source that points to a collection of data and provides information
about the drivers necessary to access it.
A data source may be either an individual table or a collection of tables stored
in an environment, catalog, or schema. Environments, catalogs, and schemas
are hierarchical database elements used by most database management systems that help you organize your data. They are in many ways analogous to
a Windows-based directory structure: you can think of the environment as a
folder that holds additional subdirectories of catalogs. Catalogs in turn contain
additional subdirectories of schemas. Each schema is a collection of tables.
The configuration process varies slightly for different database systems. For
example, server-based databases such as Oracle and Microsoft SQL Server™
require that you enter a valid user name and password and specify the network location where the database is located. File-based systems such as
Microsoft Access and dBASE III do not require this information. Because of
these variations, it is not possible to provide a generic configuration
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procedure that works for all databases. Individual procedures for configuring
all the databases that AutoCAD supports are provided in the acad_dpg.hlp file
in the AutoCAD Help system. You should also refer to the documentation for
your particular database system and the Microsoft Help files for ODBC and
OLE DB for additional information.
The connectivity feature supports the following external applications:
■
■
■
■
■
■
■

Microsoft Access 97
dBASE V and III
Microsoft Excel® 97
Oracle 8.0 and 7.3
Paradox 7.0
Microsoft Visual FoxPro® 6.0
SQL Server 7.0 and 6.5

AutoCAD 2002 includes several Microsoft Access sample database tables
and a preconfigured direct driver (jet_dbsamples.udl) that you can use to
work with these tables. You do not need to have Access installed in order
to work with these files. If you accepted the default AutoCAD installation
directory when installing AutoCAD, these files are located in
c:\Program Files\AutoCAD 2002\Sample. If you moved the Sample folder to a
different location, you must update the jet_dbsamples.udl configuration file
before you can work with these tables.
The dbConnect Manager
The dbConnect Manager is a dockable, resizable window that contains a set
of buttons and a tree view. In the dbConnect Manager, you can open the
Data View window to view or edit a database table. You can also associate various database objects (such as link templates, label templates, and queries)
with an AutoCAD drawing.
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The tree view of the dbConnect Manager contains the following nodes:
■
■

Drawing Nodes. Display each open drawing. Each drawing’s node shows
all database objects that are associated with the drawing.
Data Sources Node. Displays all configured data sources on your system.

All of the various nodes and database objects in the dbConnect Manager have
shortcut menu options associated with them. For example, you can use shortcut menu options to configure a data source or edit a stored query.
To open and close the dbConnect Manager
■

From the Tools menu, choose dbConnect.

Command line DBCONNECT
To update the jet_dbsamples.udl configuration file with new information
1 From the Tools menu, choose dbConnect.
2 From the dbConnect menu, choose Data Sources ➤ Configure.
3 From the Configure a Data Source dialog box, select Jet_dbsamples from
the Data Sources list, and then choose OK.
4 On the Connection tab of the Data Link Properties dialog box, choose the
[...] button.
5 In the Select Access Database dialog box, navigate to and select the
db_samples.mdb file, and then choose Open.
This file is located in the AutoCAD Sample folder.
6 Choose Test Connection to verify that your connection is working
properly.
7 If the connection fails, verify that you selected the appropriate file.
8 Choose OK to exit each dialog box.

View Data in a Database Table
Once you have configured a data source, you can access its tables from within
AutoCAD. The Data View is a window where you can view and edit database
records. You can open tables in Read-only mode or in Edit mode. You cannot
add, delete, or edit records in a table that you open in Read-only mode.
Opening a table establishes a connection to its parent database. Some database
systems require that you enter a valid user name and password before you
can connect to them.
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The Data View window is a spreadsheet-like environment that presents a database table’s records. With the scroll bars and navigation buttons at the right
and at the bottom of the window, you can move through the record set.

go to first record

go to last record

go to previous
record

go to next record

The grid in the Data View window contains the following elements:
■
■
■
■

grid header
record header

Column header. Selects all records in a column when you click it.
Record header. Selects an individual record when you click it.
Grid cells. Selects one field of a given record when you click it.
Grid header. Selects the entire table.

column header
grid cell

The Data View window provides a great deal of flexibility in how records are
displayed. You can
■
■
■
■
■
■

Move or resize columns
Hide columns to remove them from the Data View window display
Sort column data in ascending or descending order
Freeze a column or combination of columns so that they stay in place and
do not scroll with the horizontal scroll bar
Align text within individual columns
Apply a variety of font styles and sizes to the Data View window display

Column formatting and table sorts in the Data View window are not stored.
This information is discarded when you open a new table or close the current
table. If you want to create and save a formatted report, you must copy the
contents of the Data View window to the Clipboard and paste it into an
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external program such as Microsoft Excel. You can then use the external program to apply and save the desired formatting. For details about creating a
template, refer to the documentation of the external program that you are
using to format the data.
Database Views and External Queries
Some database management systems support views. Views provide additional
ways to display data from a table. For example, you can use a view to display
a subset of the overall table. You can also use views to define relationships
between tables and create a new table that contains combined records from
the original tables.
Database systems that do not support views can produce similar results with
queries. Refer to your database system documentation for information about
creating and working with views and queries.
AutoCAD displays views and external queries in the Data Sources node of the
dbConnect Manager. External queries are queries created and stored outside of
AutoCAD but within an external database system. Using AutoCAD, you can
work with external queries and views as you would work with any other
table. You can view or edit them in the Data View window, construct queries
based on them, and create links and labels based on their records.
To open a table for viewing or editing
1 From the dbConnect menu, do one of the following:
■
■

Choose View Data ➤ View External Table to open a table in Read-only
mode.
Choose View Data ➤ Edit External Table to open a table in Edit mode.

If required by the database that you are connecting to, AutoCAD prompts
you to enter a valid user name and password.
2 In the Select Data Object dialog box, navigate to and select the table you
want to open, and then choose OK.

NOTE Some database systems require that you obtain access privileges before
you can view or edit database tables. Refer to the documentation for your database system, or check with your database administrator.
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To open a table directly from the Data Sources node of the dbConnect
Manager
■

Double-click a table in the dbConnect Manager.
By default, AutoCAD opens double-clicked tables in Edit mode. You can
change the default double-click behavior to Read-only mode, if desired.

To change the double-click open setting for database tables
1 From the Tools menu, choose Options.
2 On the System tab, select Open Tables in Read-only Mode.
3 Choose OK.
To move a column
1 Click the column header of the column that you want to move.
2 Click the column header again and drag it to the desired location.
To resize a column
1 In the Data View window, select the grid line at the right border of the column header of the column you want to resize.
2 Drag to the right to enlarge the column, or to the left to shrink it.
To hide a column
1 In the Data View window, select the column header of the column that
you want to hide.
2 Right-click the column header, and then choose Hide.
To display all hidden columns
■

Right-click any column header in the Data View window, and then choose
Unhide All.

To specify a sort order for the Data View window display
1 Right-click any column header in the Data View window, and then choose
Sort.
2 Select a column to sort in the Sort By list, and then choose Ascending or
Descending to specify a sort order.
3 Ascending order sorts the column starting with the smallest value and
ending with the largest value. Descending order sorts the column starting
with the largest value and ending with the smallest value.
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4 If desired, select an additional column to sort in the Then By list, and then
choose the Ascending or Descending option to specify a sort order.
5 The sort operation sorts all table records according to the value specified
in the Sort By list, and then continues to sort based on the value specified
in the Then By list.
6 Repeat step 3 for any additional fields that you want to add to the sort.
You can sort by a combination of up to five table columns at a time.
To freeze a column or columns
1 In the Data View window, select one or more columns to freeze.
2 Right-click one of the selected column headers, and then choose Freeze.

NOTE The Freeze option can only be applied to contiguous columns. If not all
of the columns you want to freeze are contiguous, move them as described in
“To move a column” on page 714.
To unfreeze all frozen columns
■

Right-click any column header in the Data View window, and then choose
Unfreeze All.

To align text in a column or columns
1 Select one or more columns in the Data View window whose text you
want to align.
2 Right-click any column header, and then choose Align.
3 Choose one of the following to align the text:
■
■
■
■

Standard. Right-aligns numeric fields and left-aligns all other fields.
Left. Left-aligns the column cells.
Center. Center-aligns the column cells.
Right. Right-aligns the column cells.

To select a font size and style for the Data View
1 From the Data View menu, choose Format.
2 Select the font settings you want to use, and then choose OK.
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To export data from the Data View window
1 Open a database table by double-clicking it in the dbConnect Manager.
2 Select the records that you want to export from the Data View window.
3 Right-click in any cell, and then choose Copy.
4 Open the external application that you want to export the data to, and
then choose Edit ➤ Paste.
The text is inserted into the external application in tab-delimited format.

Edit Data in a Database Table
If you have opened a table in Edit mode, you can edit its data in a number of
ways. You can add or delete records, or edit a record’s values. You can also
search a particular column for occurrences of a specific value.
Changes that you make to individual records in a table are not written to the
database until you commit them. The Commit option updates the database
table currently loaded in the Data View window with any changes that you
make during an editing session and closes the Data View window. The Restore
option undoes any changes you made in the Data View window during an
editing session and closes the Data View window.
To help you track your editing during a work session, AutoCAD marks changed
records with an edit icon. You can easily review your changes before committing them to the source database table.
To edit a database record
1 Select a cell to edit in the Data View window.
2 Enter a new value in the cell.
3 Repeat as necessary for any additional cells that you want to edit.
You can use the keyboard arrow keys to move from cell to cell.
To add a new database record
1 In the Data View window, select a record header.
2 Right-click the record header, and then choose Add New Record.
AutoCAD adds a new record with blank field values to the end of the
current record set.
3 Select a cell in the new record and enter a value.
4 Repeat step 3 for any additional fields.
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To delete a database record
1 In the Data View window, select the record header of the record that you
want to delete.
2 Right-click the record header, and then choose Delete Record.
To search the Data View window for a particular value
1 Select a cell in the column that you want to search.
2 From the Data View menu, choose Find.
3 Enter a value to search for in Find What.
4 Select a direction to search the Data View window:
■
■

Up. Searches the column records from the selected cell through the first
record.
Down. Searches the column records from the selected cell through the
last record.

5 Choose Find Next.
6 Repeat step 5 to find additional occurrences of the specified value.

NOTE The Find option limits its search to records contained in the same column as the currently selected cell. There is no way to issue a global Find command that searches the entire database table for a specific value. You must select
individual cells in any additional columns you want to search, and then choose
Find.
To search the Data View window for a particular value to replace
1 Select a cell in the column that you want to search.
2 From the Data View menu, choose Replace.
3 Enter a value to search for in Find What.
4 Enter a replacement value in Replace With.
5 Choose Find Next.
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6 Do one of the following:
■
■

Choose Replace to replace the current occurrence of the search value.
Choose Replace All to replace all occurrences of the search value.

7 Repeat steps 5 and 6 to replace additional occurrences of the value you’re
searching for.

NOTE The Replace option limits its search to records contained in the same
column as the currently selected cell. There is no way to issue a global Replace
command that searches the entire database table for a specific value. You must
select individual cells in any additional columns you want to search, and then
choose Replace again.
To commit Data View window editing
■

Right-click the Data View grid header, and then choose Commit.

To restore original values to the Data View window
■

Right-click the Data View grid header, and then choose Restore.

NOTE If you quit AutoCAD, open a new table, or close the Data View window
before committing changes you’ve made to a database table, AutoCAD automatically commits all changes you’ve made during an editing session.

Link Database Records to Graphical Objects
Links connect graphical objects with tables in an external database.

Create and Edit Links and Link Templates
The primary function of the database connectivity feature is to associate
external data with AutoCAD graphical objects. You can, for example, associate information contained in a room database with a polyline object representing a room boundary in an AutoCAD drawing. You establish the association between the graphical object and the database table by creating a link,
which references one or more records stored in the table. You cannot create
links to nongraphical objects such as layers and linetypes.
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Links are tightly connected with the graphical objects they are associated
with. If you move or copy a linked object, the link is moved or copied with
it. If you delete a linked object, the link is also deleted.
When you create a link, a dynamic relationship is established between the
database record and the object. If, for example, you convert a room from a
storage area to an office in the database table, AutoCAD provides a mechanism to update the information stored in the drawing so that it matches the
table.
To establish links between table records and graphical objects, you must first
create a link template. Link templates identify what fields from a table are
associated with the links that share that template. For example, you can
create a link template that uses the field Room Number from a room database
table. You can then use this link template to create links that point to different records in the database table.
Link templates also function as shortcuts that point to the database tables
that they’re based on. You can use the link templates that are associated with
a drawing to open the tables that they reference for viewing or editing. This
is particularly useful if you have a large number of data sources configured
on your system. Rather than scrolling through a list of data sources each time
you want to locate an individual table, you can open it directly from the
drawing node of the drawing that it is associated with. To open a link template’s table, right-click a link template in the dbConnect Manager and
choose View Table or Edit Table.
You can attach multiple links using different link templates to a single graphical object. This is useful when you want to associate data from multiple
database tables with an individual object.
Links in External References and Blocks
Links stored in externally referenced drawings cannot be viewed or modified
in the master drawing that they’re attached to. This information is only
available when you open the source drawing directly.
Links contained in blocks are available, but can only be accessed through the
REFEDIT command.
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Edit Link Templates
Occasionally after creating a link template, you may want to edit it. For
example, you might decide to add an additional key field or remove an existing one. You also may need to update a link template if any changes are made
to the data source it points to. For example, you might rename a database
table or move it to a different location.

NOTE You can only change the key fields of link templates that don’t have any
links defined in their associated drawing. Changing the key fields of a link template invalidates its links and breaks their association to the database table. To
edit a link template with links already defined, you must first delete all links based
on the link template from its associated drawing.
Edit Links
After you have created links, you may periodically need to update their key
field values. For example, you might change the numbering scheme for a
group of offices, or reallocate some rooms from the accounting department
to the sales department. You can use the Link Manager to enter new key
values for a selected link. The key values must reference a record that already
exists in the source database table.

To create a link template in the current drawing
1 From the dbConnect menu, choose Templates ➤ New Link Template.
2 In the Select Data Object dialog box, navigate to and select a table, and
then choose Continue.
3 In the New Link Template dialog box, enter a name for the link template
in New Link Template Name, and then choose Continue.
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4 Select one or more key fields by clicking in their check boxes.
You should keep the number of key fields to a minimum. Large numbers
of key fields can have a negative impact on the performance of Link Select
and other connectivity operations.
5 Choose OK to create the link template.
To create a link
1 In the dbConnect Manager, open a table that has at least one link template defined.
2 In the Data View window, select the link template that you want to use
from the Link Template list.
3 In the Data View window, select one or more records that you want to
link.
4 From the Data View menu, choose Link and Label Settings ➤ Create Links.
5 From the Data View menu, choose Link.
6 Select one or more objects in the AutoCAD drawing that you want to link
the data to.
7 Press ENTER .
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To edit a link template
1 From the dbConnect menu, choose Templates ➤ Edit Link Template.
2 In the Select a Database Object dialog box, select a link template to edit,
and then choose Continue.
3 Select one or more key fields from the list by clicking their check boxes.
4 Choose OK to save your changes to the link template.
To update a link template’s properties
1 From the dbConnect menu, choose Templates ➤ Link Template
Properties.
2 In the Select a Database Object dialog box, select a link template, and then
choose Continue.
3 In the Link Template Properties dialog box, update the data source information as appropriate, and then choose OK.
To delete all links based on a link template from the current drawing
1 From the dbConnect menu, choose Links ➤ Delete Links.
2 From the Select a Database Object dialog box, select the link template
whose links you want to delete, and then choose OK.
To edit a link’s key values using the Link Manager
1 From the dbConnect menu, choose Links ➤ Link Manager.
2 In the AutoCAD drawing, select a linked object.
3 Note that the Link Manager can only work with one graphical object at a
time.
4 In the Link Manager, select a link from those available for the selected
object in the Link Templates list.
5 Enter a new value in the Value field of the key field you want to edit, or
choose the [...] button. Repeat, if necessary, for any additional key fields
that you want to edit.
The [...] button displays a list of all values for the specified field from the
database table, allowing you to select the value you want. After selecting
a value, choose OK.

NOTE The [...] button is only available if you are connected to the data
source that the selected link references.
6 Choose OK to update the link and close the dialog box.
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Identify and Select Existing Links
After you have created links to AutoCAD graphical objects, you may want to
view the data that is associated with them. For example, suppose you have
linked employee database records to an office layout and you want to locate
a particular employee’s office in the drawing. You can select the employee’s
record in the Data View window to select any corresponding linked graphical
objects in your drawing. Conversely, you can select AutoCAD objects to
select any linked database records in the Data View window.
Automatic Selection of Linked Objects
You can set up AutoCAD to automatically select linked graphical objects in
your drawing as additional records are selected in the Data View window.
Conversely, you can set up AutoCAD to select linked database records as
additional graphical objects are selected in your drawing. Only one of these
automatic viewing modes can be active at a time.
Other Display Options
You can use the Data View and Query Options dialog box to set a number of
viewing options that affect how linked records and linked graphical objects
are displayed whenever a corresponding linked item is selected.

The Automatically Pan Drawing option automatically pans the AutoCAD
drawing to display objects that are associated with the current selection set of
records in the Data View window. If you have multiple records selected in the
Data View window, AutoPan may not be able to fit all of them in the drawing
window with your drawing’s current zoom factor. To control for this, you can
set a zoom factor for the AutoPan mode that ensures that all linked objects
associated with the current record set are displayed.
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The Automatically Zoom Drawing option automatically zooms the AutoCAD
drawing so that all objects associated with the current record set are displayed.
You must specify a zoom factor that sets the size of the extents of the indicated
object set to a defined percentage of the drawing area. The available range
is 20 percent to 90 percent, and the default value is 50 percent. A value of
50 percent means that either the height of the extents is 50 percent of the
height of the drawing area, or the width of the extents is 50 percent of the
drawing area, whichever is less.
You can also specify the following link viewing settings:
■

■

Record Indication Settings. Specify whether all records or only the subset
associated with the current selection set of graphical objects are displayed
in the Data View window. If the Show All Records, Select Indicated Records
option is selected, you can specify a marking color to apply to the linked
records.
Accumulate Options. Specify whether AutoCAD accumulates selection
sets of linked graphical objects or Data View records, or creates new selection sets as additional objects or records are selected.

For a description of all the options available, see “Data View and Query
Options Dialog Box” under DBCONNECT in the Command Reference.
To view graphical objects that are linked to a set of table records
1 In the dbConnect Manager, double-click a table to open it.
2 In the Data View window, select a link template from the Link Template
list.
3 In the Data View window, select one or more records.
4 From the Data View menu, choose View Linked Objects.
Any objects that are linked to the selected records are selected in the drawing area.
To view database records that are linked to a selection set of graphical
objects
1 In the dbConnect Manager, double-click a table to open it.
2 In the Data View window, select a link template from the Link Template
list.
3 In the AutoCAD drawing area, create a selection set of graphical objects.
4 From the Data View menu, choose View Linked Records.
By default, only table records linked to the current drawing selection set
are displayed in the Data View window. You can change the settings in the
Data View and Query Options dialog box to display all records, if desired.
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To automatically view graphical objects that are linked to a set of table
records
1 In the dbConnect Manager, double-click a table to open it.
2 In the Data View window, select a link template from the Link Template
list.
3 From the Data View menu, choose AutoView Linked Objects.
4 In the Data View window, select one or more records.
Any corresponding linked graphical objects are selected in the drawing
area.
5 Repeat step 4 to select additional linked graphical objects.
6 Repeat step 3 to turn off the AutoView Linked Objects mode.
To automatically view table records that are linked to a selection set of
objects
1 In the dbConnect Manager, double-click a table to open it.
2 In the Data View window, select a link template from the Link Template
list.
3 From the Data View menu, choose AutoView Linked Records.
4 In the drawing area, select one or more graphical objects.
By default, only table records linked to the current drawing selection set
are displayed in the Data View window. You can change the settings in the
Data View and Query Options dialog box to display all records, if desired.
5 Repeat step 4 to select additional linked records.
6 Repeat step 3 to turn off the AutoView Linked Records mode.
To specify additional link viewing settings
1 From the Data View menu, choose Options.
2 In the Data View and Query Options dialog box, change the default
settings as desired.
3 Choose OK to save your changes and close the dialog box.
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Find and Correct Link Errors
It is recommended that you periodically check the links in your drawings to
update or delete broken links. AutoCAD provides a Synchronize option to
analyze the links in a drawing that are based on a particular link template.
After you run the Synchronize option, AutoCAD provides a list of detected
errors in the Synchronize dialog box. Certain errors (such as a resized column
in the source database table) can be fixed directly from the Synchronize
dialog box. Other errors (such as links that point to non-existent records)
must be fixed in the source database table.
To synchronize the links in a drawing
1 From the dbConnect menu, choose Synchronize.
2 In the Select a Database Object dialog box, select a link template, and then
choose Continue.
If no errors are detected, AutoCAD displays a message. If there are errors,
they are summarized in the Synchronize dialog box.
3 In the Synchronize dialog box, select an error and do one or more of the
following:
■
■
■

Choose Indicate Drawing Objects to highlight the linked graphical
objects.
Choose Fix to fix the broken link.
Choose Delete to delete the broken link.

4 Repeat step 3 for any additional errors.
5 Choose Close.

Export Link Information
You can use AutoCAD to export links contained in a drawing. This is useful
when you have multiple graphical objects linked to a single database row.
Suppose, for example, that you want to prepare a bill of materials that
summarizes the number of different light fixtures in an AutoCAD drawing.
The external database that your drawing is linked to does not contain this
information. All the database provides is a list of the various light fixtures
that make up its record set. The table has no knowledge of the number of
instances of individual light fixtures in your AutoCAD drawing. If you want
to prepare a summary report containing this information, you have to export
the links in your drawing.
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To export links from an AutoCAD drawing
1 From the dbConnect menu, choose Links ➤ Export links.
2 Create a selection set of AutoCAD graphical objects whose links you want
to export.
If more than one link template exists for the set of graphical objects that
you select, the Select Link Template dialog box is displayed and you are
prompted to select a link template. If your selection set contains only one
link template, the Export Links dialog box is displayed.
3 In the Export Links dialog box, select the fields to include by clicking
them in the Include Fields list.
4 The key fields for the selected link template are included automatically.
AutoCAD also exports the entity handle of the object that each link is
associated with.
5 Enter a name for the exported file in File Name.
6 Select a file format for the file from the Save As Type list.
7 You may save the file in the native database format of the current table or
as a comma-delimited or space-delimited text file.
8 Choose Save to export the links and close the dialog box.
9 Repeat steps 1 through 6, as necessary, for any additional link templates
whose links you want to export.

Use Labels to Display Database Information
in the Drawing
Labels are multiline text objects that display data in a AutoCAD drawing
from selected fields stored in an external database table.

Create and Edit Labels and Label Templates
Links provide a powerful mechanism for associating external data with
AutoCAD graphical objects. By selecting linked objects, you can readily
access their associated records in the database table. Links do, however, have
some inherent limitations. Suppose, for example, that you wanted to print
an AutoCAD drawing and include the external data associated with individual links. Because the links are merely pointers to the external database table,
the external data would not appear in your printed drawing. For those occasions when you want a visible representation of external data in a drawing,
AutoCAD provides labels.
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Labels are multiline text objects that display data in an AutoCAD drawing
from selected fields stored in an external database table.
The labels that you create in AutoCAD can be freestanding, or they can be
attached to a graphical object. Freestanding labels exist in the drawing independent of any graphical objects. Labels that are attached to a graphical
object are tightly connected with it. If you move the graphical object, the
label moves with it. If you copy the object to the Clipboard, the label is also
copied. If you delete an object that has an attached label, the label is deleted
as well. Labels associated with graphical objects are displayed with a leader.
To work with labels, you must first create a label template that defines what
fields from the database table are displayed in the label and how the label
text is formatted.

Edit Label Templates
After defining a label template, you might have cause to edit it. For example,
you may decide that you want additional table fields to be displayed in your
drawings, or that you want to change the font or size of the label object. You
can also specify a number of offset settings that affect the insertion point of
labels and, in the case of attached labels, their associated leader objects.
The Label Offset tab of the Label Template dialog box specifies X and Y
coordinate offset values for labels and leader objects. The following table
summarizes the effect these settings have on both freestanding and attached
labels.
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Label Offset tab options
Option

Freestanding labels

Attached labels

Start

N/A

Specifies the start point for the leader object. The
point is defined with respect to the extents of the
graphical object that the label is attached to.
Suppose, for example, that you specify a Start setting
of Top Left for a label attached to a rectangle
graphical object. The tip of the leader is inserted in
the upper left corner of the rectangle.

Leader
Offset

N/A

Specifies an X and Y offset for the multiline text object
with respect to the associated leader object. By
default, the X and Y Leader Offset options are set to
1, indicating that the label text is offset 1 unit in the X
and Y planes from the tip of the leader object.

Tip
Offset

Specifies an X and Y label offset
from the insertion point you specify
for the label. For example, X and
Y Tip Offset settings of –1 cause the
label to be inserted offset 1 negative
unit in the X and Y planes from the
insertion point you specify in the
AutoCAD drawing.

Specifies an X and Y offset for the tip of the leader
object from the value specified with the Start option.
Suppose, for example, that you specify a Start setting
of Top Left for a label attached to a rectangle
graphical object. You also specify X and Y Tip Offset
values of 1. The tip of the leader is inserted offset 1
positive unit in the X and Y planes from the upper left
corner of the rectangle.

Edit Labels
Once you have created labels, you can edit and manipulate them in a variety
of ways. Labels and their leaders can be moved and resized using standard
AutoCAD commands such as COPY, MOVE, and SCALE. It is important to note
that changes made to individual label instances do not affect or redefine the
label template. You must edit the label template as described in “To edit a
label template” on page 731.

NOTE It is not recommended that you edit the text of labels using the Multiline Text Editor. The new text values are not updated in the link or the database
table, and original field values are restored if you choose Reload. If you want to
change field values for an existing label, edit the link values as described in “Create and Edit Links and Link Templates” on page 718 and choose Reload.
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To create a label template
1 From the dbConnect menu, choose Templates ➤ New Label Template.
2 In the Select a Database Object dialog box, select a link template to use in
conjunction with the label template and then choose Continue.
3 In the New Label Template dialog box, enter a name for the label template
in New Label Template Name.
4 To open the Label Template dialog box, choose Continue.
The Label Template dialog box is a modified version of the Multiline Text
Editor. Two additional tabs control the creation of labels.
5 In the Label Template dialog box, choose the Label Fields tab.
6 Select a field to appear in the label from the Field list, and choose Add to
add it to the label.
You can also enter any additional static text that you want to precede or
follow the label directly in the Label Template dialog box. For example,
you might create a label template that uses the field Room Number from
a room database table. If you want the field name to precede the field
value when the label is created, enter Room Number: in the Label Template dialog box before selecting the field from the Field list.
7 Repeat step 6 for any additional fields that you want displayed in your
label.
8 Choose OK to save your changes and close the dialog box.

To create a link with a freestanding label
1 In the dbConnect Manager, open a table that has at least one link template and one label template defined.
2 In the Data View window, select a link template from the Link Template
list.
3 In the Data View window, select a label template from the Label Template
list.
4 In the Data View window, select the record that you want to link.
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5 From the Data View menu, choose Link and Label Settings ➤ Create
Freestanding Labels.
6 From the Data View menu, choose Link.
7 Select an area in the AutoCAD drawing to insert the label.
To create a link to an object with an attached label
1 In the dbConnect Manager, open a table that has at least one link template and one label template defined.
2 In the Data View window, select a link template from the Link Template
list.
3 In the Data View window, select a label template from the Label Template
list.
4 Select the record that you want to link from the Data View window.
5 From the Data View menu, choose Link and Label Settings ➤ Create
Attached Labels.
6 From the Data View menu, choose Link.
7 Select an object or objects in the AutoCAD drawing that you want the
label associated with.
8 Press ENTER .
To edit a label template
1 From the dbConnect menu, choose Templates ➤ Edit Label Template.
2 In the Select a Database Object dialog box, select a label template to edit.
3 Choose Continue.
4 Make the changes you want as described in “To create a label template” on
page 730.
To specify label formatting
1 Create a new label template as described in “To create a label template” on
page 730.
2 Select text formatting options using the Character and Properties tabs, as
described in MTEXT in the Command Reference.
3 Choose the Label Offset tab.
4 In the Label Offset tab, specify the insertion point for the tip of the leader
object in Start.
The Start setting has no effect on freestanding labels.
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5 Enter both X and Y offset values in Leader Offset to specify the offset of
the label from the tip of the leader object.
By default, the X and Y offset values are set to 1, indicating that the label
is offset by one drawing unit in both the X and the Y directions from the
tip of the leader object.
6 Enter both X and Y offset values in Tip Offset to specify the offset for the
leader object or, for freestanding labels, the offset of the label from the
insertion point you specify for the label.

Update Labels with New Values from the
Database
After you have added labels to your AutoCAD drawings, you may make occasional changes to the database tables that affect the label values. If you make
frequent changes to your database tables, you must regularly update the
labels in your drawings to ensure data integrity.
To update all label values in the current drawing
1 From the dbConnect menu, choose Labels ➤ Reload Labels.
2 In the Select a Database Object dialog box, select the label template whose
values you want to reload. Choose OK.

Use Queries to Filter Database Information
A query to the database is a search criterion that you construct to return the
records you want.
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Overview of Queries
Part of the fundamental power of database systems is their ability to present
a subset of records based on a search criterion or query that you specify. For
example, you might have a database table containing records of all the rooms
that exist at your company’s headquarters facilities. Suppose that you want
to prepare a report that lists all conference rooms that can seat more than 20
people. Using the AutoCAD Query Editor, you can easily construct a query
that returns the subset of records or linked graphical objects that you want
to see.
The Query Editor consists of a series of four tabs that you can use to develop
queries. The tabbed progression is designed to make working with queries
simple, even if you are not familiar with Structured Query Language (SQL).
If you are unfamiliar with queries, work with the Quick Query and Range
Query tabs initially until you become familiar with query syntax. Once you
learn the basics involved in developing meaningful queries, you can progress
to the Query Builder and SQL Query tabs.
You can begin creating a query in one tab and continue to refine it or add
additional parameters in subsequent tabs. You might, for example, begin
creating a simple query in the Quick Query tab and subsequently decide that
you would like to add an additional condition using the Query Builder tab.
When you choose the Query Builder tab, it displays the values that you
initially selected using the Quick Query tab, and you can add additional
conditions to the query. However, you cannot move backwards through the
tabs once you have changed the query in one of the later tabs, because each
subsequent tab provides additional functions that are not available in the
previous tabs. If you attempt to move backwards through the query tabs after
modifying a query, AutoCAD prompts you with a warning indicating that
the query will be reset with its original default values.
The tabbed progression of the Query Editor is particularly useful in becoming
familiar with SQL syntax. For example, you can create a query using the
Quick Query tab and then select the SQL Query tab to view how your query
is formatted using SQL.
The Query Editor provides the following tabs for building queries:
■

Quick Query. Provides an environment where you can develop simple
queries based on a single database field, single operator, and single value.
For example, you can find all records from the current table where the
value of the "room type" field equals "office".
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■

■

■

Range Query. Provides an environment where you can develop a query
that returns all records that fall within a given range of values. For example, you can find all records from the current table where the value of the
"room area" field is greater than or equal to 90 square feet and less than or
equal to 120 square feet.
Query Builder. Provides an environment where you can develop more
complicated queries based on multiple search criteria. For example, you
can find all records from the current table where the "room type" equals
"cubicle" and room area is greater than 80 square feet.
SQL Query. Provides an environment where you can develop
sophisticated queries that conform with the SQL 92 protocol. For
example, you can select * from california.headquarters.room where
california.headquarters.room.type = ’cubicle’
and
california.headquarters.room.area < 80.

See “Construct Simple Queries” on page 734 for detailed information about
constructing queries and working with operators. If you are already comfortable building database queries, see “Use the Query Builder” on page 738.
To open the Query Editor
1 From the dbConnect Menu, choose Queries ➤ New Query on an External
Table.
2 In the Select Data Object dialog box, navigate to and select a table, and
then choose Continue.
3 In the New Query dialog box, enter a name for the query in New Query
Name.
4 Choose Continue to open the Query Editor.

Construct Simple Queries
The simplest query uses one operator to search one field for a certain value.
The range query searches one field to return records that fall within a range
you specify.
The Quick Query Tab
The Quick Query tab is designed to familiarize you with query syntax as
quickly as possible. Constructing a quick query involves selecting a field from
the current database table, applying a conditional operator to it, and specifying
a value for the field.
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Conditional operators are constraints such as equal, greater than, or less
than. The following table summarizes the Quick Query tab’s operators.
AutoCAD query operators
Operator

Description

Equal (=)

Returns all records that exactly match the value that you specify.

Not equal (<>)

Returns all records except those matching the value that you specify.

Greater than (>)

Returns all records that exceed the value that you specify.

Less than (<)

Returns all records with values that are less than the value that you specify.

Greater than or
equal (>=)

Returns all records that exceed or equal the value that you specify.

Less than or
equal (<=)

Returns all records that are less than or equal to the value that you specify.

Like

Returns all records that contain the value that you specify. Using the like
operator, you can specify the optional % wild-card character. If, for example,
you want to return all records that end with the string "ert", you enter the
value %ert. If you want to return all records that begin with the string "ert",
you enter the value ert%. If you don’t specify the % wild-card character,
AutoCAD searches for the exact value that you specify.

In

Returns all records that match a set of values that you specify. If, for example,
you are searching for an employee record but are not sure if the name is
spelled Smith or Smythe, you could issue the in operator and provide both
spelling values to return all records spelled either Smith or Smythe. The two
values must be separated by a comma.

Is null

Returns all records that do not have values specified for the field that you’re
querying. This operator is useful for locating records in your table that are
missing data.

Is not null

Returns all records that have values specified for the field that you’re
querying. This operator is useful for excluding from your query records in
your table that are missing data.

NOTE All operators can be applied to both numeric and text-based fields. For
example, you can search for all records greater than "c", which would return all
records ranging from "ca..." through "z...". It is important to realize that query
searches are case sensitive: "ROOM" is not equivalent to "room".

Use Queries to Filter Database Information

|

735

The Range Query Tab
Like the Quick Query tab, the Range Query tab is designed to assist users who
are new to working with database queries. Using the Range Query tab, you
can specify a range of values for the query to return: for example, all rooms
that are greater than or equal to 80 square feet but are less than or equal to
100 square feet. The interface is similar to that of the Quick Query tab, except
the Operator field has been removed and the Value field has been replaced
with two fields; a From field and a Through field. All other interface features
are available and work as they do on the Quick Query tab.
To construct a quick query
1 Open the Query Editor as described in “To open the Query Editor” on page
734.

2 On the Quick Query tab, select a field from the Field list.
3 Select an operator from the Operator list.
4 Enter a value in the Value field, or choose Look Up Values.
Look Up Values returns a list of all values for the specified field from the
database table, so you can select the value that you want. After selecting a
value, choose OK.
5 Select one or both of the following:
■
■
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query in the Data View window.
Indicate Objects in Drawing. Highlights objects that match your
query in the current AutoCAD drawing.
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6 If you want to save the query in the current drawing for future use, choose
Store.
7 Choose Execute to execute the query and close the dialog box.
A subset of records that match your query criterion are displayed in the
Data View window. To return to the Query Editor to refine your query,
choose the Return to Query button.
To construct a range query
1 Open the Query Editor as described in “To open the Query Editor” on page
734.

2 Choose the Range Query tab.
3 Select a field from the Field list.
4 Enter a value in From, or choose Look Up Values (From).
Look Up Values displays a list of all values for the specified field from the
database table, so you can select the value that you want. After selecting a
value, choose OK.
The query searches for all values greater than or equal to the value that
you specify.
5 Enter a value in Through, or choose Look Up Values (Through).
The query searches for all values less than or equal to the value that you
specify.
6 If you want to save the query in the current drawing for future use, choose
Store.
7 Choose Execute to execute the query and close the dialog box.
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Use the Query Builder
The Query Builder tab is the primary AutoCAD query environment. Unlike
the Quick Query and Range Query tabs, the Query Builder can be used to
create queries based on multiple criteria. You can also parenthetically group
criteria and specify what fields are displayed and how they are sorted when
the query is returned in the Data View window.
The Query Builder tab introduces Boolean operators and parenthetical grouping, which are used to create compound queries based on two or more search
criteria. For example, using Boolean operators, you can generate a query that
returns a list of all light fixtures of a given type that were installed after a
specific date.
■

■

■

And Operator. Constructs a query based on multiple criteria, returning a
set of records that meet all specified criteria. For example, search for all
rooms that are offices and are currently unoccupied. The query returns
records for all rooms that are both offices and unoccupied.
Or Operator. Constructs a query based on multiple criteria, returning a set
of records that meet any of the specified criteria. For example, search for
all rooms that are offices or are currently unoccupied. The query returns
records for all rooms that are either offices or unoccupied.
Parenthetical Grouping. Groups a series of search criteria by bracketing
them within parentheses. For example, search for
(All rooms that are offices and are currently unoccupied)
or
(All rooms that are cubicles and are currently unoccupied)
This query returns a list of all unoccupied offices and cubicles.
You can nest up to four sets of parentheses within a statement.
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To construct a query with a single parameter on the Query Builder tab
1 Open the Query Editor as described in “To open the Query Editor” on page
734.
2 Choose the Query Builder tab.
3 Select a field from the drop-down list in the Field cell.
4 Select an operator from the Operator cell drop-down list.
5 Enter a value in the Value cell, or choose the [...] button.
The [...] button returns a list of all values for the specified field from the
database table, allowing you to select the value you want. After selecting
a value, choose OK.
6 If you want to save the query in the current drawing for future use, choose
Store.
7 Choose Execute to execute the query and close the dialog box.
To construct a query with multiple parameters on the Query Builder tab
1 Enter the first parameter of your query as described in “To construct a
query with a single parameter on the Query Builder tab” on page 739.
2 Select the appropriate And or Or operator from the Logical field.
Clicking in the Logical field inserts an And operator. Clicking the cell
again changes the value to Or.
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3 Enter additional query parameters on subsequent rows of the Query grid.
4 Repeat step 2 for each additional parameter except the final query parameter.
5 Apply any parenthetical grouping, if appropriate. Click the cell to the left
of the Field cell that begins the phrase that you want to group. A single
left parenthesis is inserted. Click the cell to the right of the Value cell that
ends the phrase that you want to group. A single right parenthesis is
inserted.
6 If you want to save the query in the current drawing for future use, choose
Store.
7 Choose Execute to execute the query and close the dialog box.
To specify what fields appear in your returned query
1 Construct your query as described in “To construct a query with a single
parameter on the Query Builder tab” on page 739 and “To construct a
query with multiple parameters on the Query Builder tab” on page 739
2 Select the first field that you want to appear in the Fields in Table list.
3 Above the Show Fields list, choose Add.
4 Repeat steps 2 and 3 for any additional fields you want to display.
To specify a sort order for your returned query
1 Construct your query as described in “To construct a query with a single
parameter on the Query Builder tab” on page 739 and “To construct a
query with multiple parameters on the Query Builder tab” on page 739
2 Select the first field that you want to sort on from the Show Fields list.
3 Above the Sort By list, choose Add.
By default, AutoCAD sorts the selected field in ascending order. Choose
the Sort button to sort in descending order.
4 Repeat steps 2 and 3 for any additional fields that you want to sort on.

Use SQL Queries
The SQL Query tab provides you with both a query editor box where you can
enter a free-form SQL query and a set of tools to assist you in constructing a
query. You can issue any valid SQL statement that conforms with Microsoft’s
implementation of the SQL 92 protocol from this tab. Because not all database management systems are fully compliant with the SQL 92 standard, you
should review your system’s documentation to see what SQL commands are
valid for your particular database.
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Unlike the other tabs in the Query Editor, the SQL Query tab can be used to
construct a query that performs relational operations on multiple database
tables using the SQL join operator. Because joins are a relatively advanced
SQL operation, refer to your database system documentation or to the SQL
92 protocol for information about working with joins.

The following additional interface elements are introduced on the SQL
Query tab:
■

■

Table List. Lists all database tables available in the current data source.
You can add tables to the SQL query editor by double-clicking them, by
selecting them and choosing Add, or by typing their names directly in the
SQL query editor.
Check. Checks your SQL query for proper syntax without actually
executing it. This function helps you isolate syntax errors before you issue
your query.

To construct an SQL query
1 Open the Query Editor as described in “To open the Query Editor” on page
734.
2 Choose the SQL Query tab.
3 Enter your query in the query editor, or select query components from the
interface as described in “Use the Query Builder” on page 738.
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4 If you want to save the query in the current drawing for future use, choose
Store.
5 Choose Execute to execute the query and close the dialog box.

Combine Queries
Link Select is an advanced implementation of the Query Editor that constructs iterative selection sets of AutoCAD graphical objects and database
records.
Link Select creates an ongoing selection set that you refine with additional
information through a running iterative process. You begin either by constructing a query or by selecting AutoCAD graphical objects. This initial
selection set is referred to as set A. You can now select additional graphical
objects or issue a query to further refine your selection set. This second selection set is referred to as set B. You must establish a relationship between set
A and set B to further refine the selection set. The following relationships or
set operations are available:
■
■

■

■
■

Select. Creates an initial query or selection set. This selection set can be
refined through subsequent Link Select operations.
Union. Adds the results of the new query or selection set to the running
selection set. This operation returns all records or objects that are members of set A or set B.
Intersect. Returns the intersection of the existing running selection and
the results of the new query or drawing selection. This operation returns
all records or objects that are members of set A and set B.
Subtract A - B. Subtracts the results of the new query or drawing selection
from the existing running selection.
Subtract B - A. Subtracts the existing running selection from the results of
the new query or drawing selection.

After you apply one of the set operations, the returned results become the
new running selection and are assigned to set A. You can continue the iterative process by creating additional B sets to further refine your Link Select set.
To use Link Select
1 From the dbConnect menu, choose Links ➤ Link Select.
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2 Select the Select option from the Do list.
3 Select a link template from Using.
4 Choose one of the following options:
■
■

Use Query. Constructs a query using one of the tabs in the Query
Editor.
Select in Drawing. Closes the dialog box temporarily so that you can
select graphical objects in the AutoCAD drawing. When you select the
Select in Drawing option, the Execute button changes to Select.

5 Choose either Execute or Select to add your query or graphical object
selection set to the Link Select operation.
6 Choose a Link Select operation from the Do list: Union, Intersect, Subtract
A-B, or Subtract B-A.
7 Repeat steps 3 through 5 to add set B to the Link Select operation.
8 Choose one or both of the following options, and then choose Finish to
complete the Link Select operation:
■

Indicate Records in Data View. Returns the results of the current Link
Select operation in the Data View window when you choose Finish.
You can perform further Link Select iterations by choosing the Return
to Link Select button in the Data View window.
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■

Indicate Objects in Drawing. Creates a selection set of linked graphical objects in the drawing area when you choose Finish. You can perform further Link Select iterations by pressing ENTER at the Command
prompt.

NOTE It is recommended that you turn off the Indicate Records in Data View
option if you are performing a Link Select operation on links from more than one
database table. Link Select only displays records from the table that the current
link template references. This limitation can cause misleading results to be
returned to the Data View window.

Save and Reuse Queries
You can save queries that you plan on using more than once with an AutoCAD
drawing. Queries that you save are listed in the dbConnect Manager under the
drawing node of the drawing that they were created in. You can edit and
rename stored queries or copy them to other drawings.
To execute a stored query
1 From the dbConnect menu, choose Queries ➤ Execute Query.
2 In the Select a Database Object dialog box, select the query that you want
to execute, and then choose OK.
To edit a stored query
1 From the dbConnect menu, choose Queries ➤ Edit Query.
2 In the Select a Database Object dialog box, select the query that you want
to edit.
3 Choose Continue.
4 Use the Query Editor dialog box to make the necessary changes, and
choose Store to save the edited query with the current drawing.
To rename a stored query
1 In the dbConnect Manager, right-click the query you want to rename.
2 Choose Rename.
3 Enter a new name for the query, and then press ENTER .
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To delete a stored query
1 From the dbConnect menu, choose Queries ➤ Delete Query.
2 In the Select a Database Object dialog box, select one or more queries to
delete from the current drawing, and then choose OK.
To copy a stored query to another drawing
1 From the dbConnect Manager, select the query that you want to copy.
2 Drag the query to the node of the drawing that you want to copy it to.
To automatically store new queries with the current drawing
1 From the dbConnect Manager, open a table by double-clicking it.
2 From the Data View menu, choose Options.
3 Select Automatically Store, and then choose OK.

Share Link and Label Templates and Queries
with Other Users
You can export and import links and link templates, labels and label templates, and queries.
Occasionally you may want to make templates or queries that you have
developed available to other AutoCAD users or use templates or queries that
others have developed. This is particularly useful when developing a set of
common tools that can be shared by all of the team members on a project,
and it eliminates the need to replicate the work of template and query development on each team member’s workstation. AutoCAD can import and
export all the link and label templates and queries that are associated with a
drawing.
To import a set of templates into the current drawing
1 From the dbConnect menu, choose Templates ➤ Import Template Set.
2 In the Import Template Set dialog box, select the template set.
3 Choose Open to import the template set into the current drawing.
If there is a link or label template with the same name already associated
with the current drawing, AutoCAD displays an alert box that you can use
to provide a unique name for the template.
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To export a set of templates from the current drawing
1 From the dbConnect menu, choose Templates ➤ Export Template Set.
2 In the Export Template Set dialog box in the Save In list, select the directory you want to save the template set to.
3 Under File Name, specify a name for the template set, and then choose
Save.
To import a set of queries into the current drawing
1 From the dbConnect menu, choose Queries ➤ Import Query Set.
2 In the Import Query Set dialog box, select the query set.
3 Choose Open to import the query set into the current drawing.
If there is a query with the same name already associated with the current
drawing, AutoCAD displays an alert box that you can use to provide a
unique name for the query.
To export a set of queries from the current drawing
1 From the dbConnect menu, choose Queries ➤ Export Query Set.
2 In the Export Query Set dialog box, select the directory you want to save
the query set to from the Save In list.
3 Under File Name, specify a name for the query set, and then choose Save.

Work with Links in Files from Earlier
Releases
Because AutoCAD 2000 and later releases store links in a different format
than previous releases, you need to convert your links if you plan on using
them with AutoCAD 2000 and later. Note the changes in terminology: key
value replaces key column in Release 14; link template replaces link path name;
and label replaces displayable attribute. You also need to create a configuration
file that points to the data source referenced by the legacy links.
When you open a drawing that contains legacy links, AutoCAD attempts to
perform an automatic conversion of the legacy information. If, for example,
you open a Release 14 drawing that contains links that point to a data source
with the structure db3.ase.db3sample.computer(com), AutoCAD attempts to
establish an exact, one-to-one mapping of the data source components.
In some cases, the legacy data source might not match exactly how the data
source is configured. For example, the legacy data source might specify a
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catalog that isn’t specified in the data source. If the automatic link conversion is unsuccessful, you can use the new Link Conversion dialog box to
establish a mapping between the legacy and new data sources. You can also
use the Link Template Properties dialog box to specify new data source
parameters for a selected link template.
During the conversion process, AutoCAD writes the data source mapping
information to a file called asi.ini that is stored in the AutoCAD 2002 folder.
You can manually edit the conversion mapping information specified in this
file, if necessary.

NOTE AutoCAD attempts to automatically convert legacy links only for data
sources that don’t have mapping values specified in the asi.ini file. Once you
have specified conversion mappings for a particular data source, AutoCAD uses
the settings specified in the asi.ini file for any additional legacy drawings you
open that contain links that reference this data source.
Save Links to Earlier Formats
Links that you have created in AutoCAD 2000 and later can be converted to
Release 13 or Release 14 links. AutoCAD 2000 and later links cannot be converted to Release 12 format. When you use SAVEAS to save a drawing in the
current format that contains links to Release 13 or Release 14 format, the
links are automatically converted to the appropriate drawing format. You
must specify a conversion mapping as described above.
To convert AutoCAD Release 13 and Release 14 links
1 From the dbConnect menu, choose Link Conversion.
2 In Old Link Format, do all of the following:
■
■
■
■
■
■

Select R13/R14 Link Format.
Enter the name of the Release 13 or Release 14 environment for the link
that you want to convert in Environment.
Enter the name of the Release 13 or Release 14 catalog for the link that
you want to convert in Catalog.
Enter the name of the Release 13 or Release 14 schema for the link that
you want to convert in Schema.
Enter the name of the Release 13 or Release 14 table for the link that
you want to convert in Table.
Enter the link path name for the link that you want to convert in Link
Path Name.

3 In New Link Format, do all of the following:
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■
■
■
■
■

Select the appropriate data source from the Data Source list.
Select the appropriate catalog from the Catalog list.
Select the appropriate schema from the Schema list.
Select the appropriate table from the Table list.
Select the appropriate link template from the Link Template list.

4 Choose OK.
5 Open the drawing whose links you want to convert, and save it in
AutoCAD 2000 format.

NOTE You must specify an environment, table, and link path name for all
links that you convert. Catalog and schema are optional parameters that are
not required by all database management systems.
To convert AutoCAD Release 12 links
1 From the dbConnect menu, choose Link Conversion.
2 In Old Link Format, do all of the following:
■
■
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Select R12 Link Format.
Enter the name of the Release 12 database management system for the
link that you want to convert in DBMS.
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■
■

Enter the name of the Release 12 database for the link that you want to
convert in Database.
Enter the name of the Release 12 table for the link that you want to
convert in Table.

3 In New Link Format, do all of the following:
■
■
■
■
■

Select the appropriate data source name from the Data Source list.
Select the appropriate catalog from the Catalog list.
Select the appropriate schema from the Schema list.
Select the appropriate table from the Table list.
Select the appropriate link template from the Link Template list.

4 Choose OK.
■

Open the drawing whose links you want to convert, and then save it in
AutoCAD 2000 format.

Once you have specified a link conversion mapping, when you subsequently open and save in AutoCAD 2000 or later format a drawing that
contains links that are specified in the mapping, the links are converted
to the new format.
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